Campaign Email issue: Links sent in the email are not linking properly ?

Apr 28, 2015 12:07 pm

When creating a campaign email ... the links work fine. But when you send out the email.. the link urls change gives the error: The requested url not found" and it looks like the url is a tag url that its trying to track?

It seems every link within the email gets changed to a new url with an ID.... but then its not found and does not go to the original url anymore

how do i fix this?

Apr 28, 2015 12:37 pm

Hello! So that we may better help you with your issue can you please provide the website URL that you are having trouble with?

Apr 28, 2015 12:41 pm

The domain name is mghradrounds.org << I have it currently redirected to our archives page. I think the issue might be the A record for the domain name points to elsewhere to our new server instead of Rareearth where SNAP is installed?

I just changed the A record back to Rareearth hoping that will fix the issue? Is there a way to prevent accrisoft from converting the urls for tracking?

Apr 28, 2015 12:45 pm

For example... In the email... we have a link to go to an archives page: http://www.massgeneralimaging.org/newsletter/archive/

But when the email goes out... SNAP converts the link to: http://www.mghradrounds.org/index.php?cid=0&forward=1&curlid=11

and the link gives the error that the page is not found

May 6, 2015 9:36 am

Hello,

You are correct. If the A-Record is not pointing to the Freedom installation (the IP that is shown in the Green > Domains Module) and the Domain is being used in the campaigns it will give you the "Page Not Found" error. There is not a way to prevent Freedom from converting the URLs for tracking. This is a built in feature of the software.

What we recommend is create a sub-domain such as, "mail.mghradrounds.org", and configure that sub-domain as the Primary URL for the Freedom website (This is of course, if you are using the Freedom site for Email Marketing only) and use that domain as your mailing domain for SNAP and Freedom.